# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?mi)(\d+)\.\h+(.+)(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?(?:\R[a-e]\.\h+(.+))?\RAns:\h+(.+)"
test_str = ("1. Question with 4 choices\n"
"a. one a\n"
"b. one b\n"
"c. one c\n"
"d. one d\n"
"Ans: B\n\n"
"23. True-False Question with no choices\n"
"Ans: T\n\n"
"2. Question with 3 choices\n"
"a. two a\n"
"b. two b\n"
"c. two c\n"
"Ans: C\n\n"
"3. Question with 2 choices\n"
"a. three a\n"
"b. three b\n"
"Ans: B")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.