re = /\+[\d]{11,14}/i
str = 'Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:"{};\'[]|\\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~`:"{};\'[]|\\<>?,./
+9991234567
+19991234567
+129991234567
+1239991234567
+12349991234567
+1 999 1234567
+1234 (999) 123-45-67
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result