$re = '/(20\d{2}).(\d{1,2}).(\d{1,2})/m';
$str = '2020.01.01.
2020.2.28
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);