$re = '/\[\[((?:(?!\[\[).)*?)\|(.*?)]]/ms';
$str = '[[some_non-matching_text]] [[https://example.com|link]] [[this is not matching either]] [[http://example2.com|link2]]';
$subst = "<a href=\"$1\">$2</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;