using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^jdoe";
string input = @"jdoe
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}