using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^reg0[1-4]\.eset\.com$";
string input = @"reg01.eset.com
reg02.eset.com
reg03.eset.com
reg04.eset.com
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}