# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?(\b(?:to|for|with)\b.*)/\1/gm;t' <<< "I wish to check my python code for errors to run the program properly with fluency"