const regex = /.*?(\b(?:to|for|with)\b.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(\\b(?:to|for|with)\\b.*)', 'gm')
const str = `I wish to check my python code for errors to run the program properly with fluency`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);