use strict;
my $str = 'I wish to check my python code for errors to run the program properly with fluency';
my $regex = qr/.*?(\b(?:to|for|with)\b.*)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";