using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<qualifier>[+?~-])?(?P<is_a>a)(?:[:])?(?P<a_mechanism>.+)?";
string input = @"a
a:example.com
+a:example.com
a:mailers.example.com
~a:mailers.example.com
a/24
-a:offsite.example.com/24
?a:example.com/24
+mx:mail.example.com
mx
ip4:192.168.11.0/32";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}