package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?P<qualifier>[+?~-])?(?P<is_a>a)(?:[:])?(?P<a_mechanism>.+)?`)
var str = `a
a:example.com
+a:example.com
a:mailers.example.com
~a:mailers.example.com
a/24
-a:offsite.example.com/24
?a:example.com/24
+mx:mail.example.com
mx
ip4:192.168.11.0/32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}