import re
regex = re.compile(r"^(?P<qualifier>[+?~-])?(?P<is_a>a)(?:[:])?(?P<a_mechanism>.+)?", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("a\n"
"a:example.com\n"
"+a:example.com\n"
"a:mailers.example.com\n"
"~a:mailers.example.com\n"
"a/24\n"
"-a:offsite.example.com/24\n"
"?a:example.com/24\n"
"+mx:mail.example.com\n"
"mx\n"
"ip4:192.168.11.0/32")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")