// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(?P<qualifier>[+?~-])?(?P<is_a>a)(?:[:])?(?P<a_mechanism>.+)?").unwrap();
let string = "a
a:example.com
+a:example.com
a:mailers.example.com
~a:mailers.example.com
a/24
-a:offsite.example.com/24
?a:example.com/24
+mx:mail.example.com
mx
ip4:192.168.11.0/32";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}