package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(1?)(?:((\s?\(\d{3}\)\s?|\s?\d{3}\s?)\-?\d{3}\s?\-?\d{4}$))`)
var str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1 (555) 555-5555
2 (757) 622-7382
(6054756961)
55555555
123**&!!asdf#
555-5555
1 555)555-5555
(6054756961)
(555-555-5555
555)-555-5555
(275)76227382`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}