Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
Let's start(.*[\r\n])*.*my friend\.
"
gm
Input 1
1
New
How much wood? Who knew! Let's start! ... blah, blah, blah... How much longer? It's joe's place*, isn't it? This is! [the end], my friend. Ok, Let's do some more testing.