const regex = /\n?(.*?DAN.*?)\n\n?(.*?)\n(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n?(.*?DAN.*?)\\n\\n?(.*?)\\n(.*)', 'gm')
const str = `DAN 1
LJUBLJANA – GORNO ALTAJSK
Odhod in vožnja proti letališču. Polet proti Moskvi.
DAN 2
GORNO ALTAJSK – KANSKA DOLINA – GORNJI UJMON – TJUNGUR – KUČERLA
Zjutraj pristanek na letališču. Transfer preko Seminskega prevala v Kansko dolino. Ogled Taldinskih kurganov, jame Beli kamen, muzej Rericha v Gornjem Ujmonu, postanek v Ust Koksi. Zvečer prihod v Tjungur (v prevodu šamanski boben) in preko reke Katun v Kučerlo.
DAN 3
TREKING S KONJI
Čez prelaz Kuzujak (1513m) v dolino reke Akkem, kjer taborimo (35 km)
DAN 4
TREKING S KONJI
Po dolini ob potoku nadaljujemo sprva zmerno, nato pa vedno bolj strmo navzgor. Za nami ostaja prvobitni sibirski gozd, pred nami se razprostirajo gorski travniki z bujno vegetacijo. Na pobočju gore Tukman s čudovitimi pogledom na Beluho postavimo na višini 2000m naš drugi tabor. 6-7 h, 14 km, 900 v.m.
DAN 5
TREKING S KONJI
Pot nas vodi ob reki Aktaš po visoki planoti do slikovitega jezera, vseskozi nas spremlja panorama na zasnežene vrhove. Tabor postavimo v cedrinem gozdu na višini 2000m. 7-8 h, 20 km, 100 v.m.
DAN 6
TREKING S KONJI
Zmeren vzpon na vrh Černaja (3019m) in spust k reki Tekelju na višini 1800m, kjer bo naš četrti tabor. To področje se omenja tudi kot življenski prostor snežnega leoparda! Kratek izlet do dveh divjih slapov nižje ob reki in povratek v tabor. 5-6 h, 18 km, 700 v.m.
DAN 7
TREKING S KONJI
Pot nas vodi po odprtih razglednih planotah in grebenih do doline Jarlu in do Akkemskega jezera na višini 1950m. Tu bo naš tabor naslednja dva dni. 7-8 h, 15 km, 600 v.m.
DAN 8
AKKEMSKO JEZERO
Počitek ob jezeru, po želji izlet na ledenik pod Beluho, do jezera Gornjih duhov, do Sedmerih jezer ali do »kamnitega mesta« v dolini Yarlu.
DAN 9
AKKEMSKO JEZERO
Začetek drugega dela našega trekinga v Sibiriji. Vzpon na prelaz Karatjurek, ki je s 3060m najvišja točka našega trekinga. Nepozaben pogled na Beluho, ledenik in jezero Akkem. Spust v dolino reke Kučerle in postavitev tabora v cedrinem gozdu. 6-8 h, 15 km, 1000 m
DAN 10
TREKING S KONJI
Po kratkem vzponu na gozdni plato nadaljujemo s spustom do Kučerlinskega jezera na višini 1760m. Za razliko od ledeniškega Akkemskega jezera, je to jezero bolj globoko in polno rib. Tu postavimo naš naslednji tabor. 4-6 h, 13 km, 300 v.m.
DAN 11
KUČERLINSKO JEZERO
Po dolini reke Kučerle se v zmernem spustu po značilni sibirski tajgi vračamo proti domu. Na bregu reke postavimo naš zadnji tabor na trekingu. 7-8 h, 21 km, 460 v. m.
DAN 12
TREKING S KONJI
Nadaljujemo s spustom ob reki, ob poti si ogledamo starodavne petroglife na skali. Zvečer nas v vasi Kučerla čaka tradicionalna altajska pogostitev in savna. 4-6 h, 24 km, 450 v.m
DAN 13
KUČERLA – GORNO ALTAJSK/BARNAUL
Povratek v Gorno Altajsk, na poti ogled muzeja Rericha in galerije kamnov, namestitev v hotelu v Gorno Altajsku, počitek.
DAN 14
GORNO ALTAJSK/BARNAUL – LJUBLJANA
Jutranji polet proti Moskvi, prihod v Ljubljano predvidoma ob 17.00.`;
const subst = `<p class="dan">$1</p>\n<p class="pot">$2</p>\n<p class="opis">$3</p>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);