package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ELSE\b(\n.*){1,}\bGO`)
var str = `BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
something here!!!
something here!!!
GO
BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
GO
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}