const regex = /^ELSE\b(\n.*){1,}\bGO/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ELSE\\b(\\n.*){1,}\\bGO', 'gm')
const str = `BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
something here!!!
something here!!!
GO
BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
GO
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}