#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(PROJETO|PROTOCOLOS) *N(º|o) *[0-9.]+ *DE *\d+ DE \b.*?\b DE \d*\."
Local $sString = "PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018." & @CRLF & _
"PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018." & @CRLF & _
"PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018." & @CRLF & _
"PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")