import Foundation
let pattern = #"(PROJETO|PROTOCOLOS) *N(º|o) *[0-9.]+ *DE *\d+ DE \b.*?\b DE \d*\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)