const regex = /(?<!&#([0-46-9]\d|5[0-8]))(?<!&#\d{3})(?<!&[a-z])(?<!&[a-z]{2})(?<!&[a-z]{3})(?<!&[a-z]{4})(?<!&[a-z]{5})(?<!&[a-z]{6})(?<!&[a-z]{7})(?<!&[a-z]{8});\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!&#([0-46-9]\\d|5[0-8]))(?<!&#\\d{3})(?<!&[a-z])(?<!&[a-z]{2})(?<!&[a-z]{3})(?<!&[a-z]{4})(?<!&[a-z]{5})(?<!&[a-z]{6})(?<!&[a-z]{7})(?<!&[a-z]{8});\\)', 'gm')
const str = `Should work
;)
;)
hey;)
nbsp;)
Should NOT work
)
ɘ)
)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}