# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(?<Event_Log>[^\"]+)\""
test_str = ("2021-12-04T01:29:48.015524+00:00 USHCO-EXXON, ipsec-ike-down, 689, \"IKE connection with peer 10.218.42.113 (routing-instance EXXON-Control-VR) is up\", USPAB\n\n"
"2021-12-04T01:29:15.007722+00:00 USHCO-EXXON, ipsec-tunnel-down, 687, \"IPSEC tunnel with peer 10.218.42.111 (routing-instance EXXON-Control-VR) is up\", USPAB\n\n"
"2021-12-04T01:29:15.007722+00:00 USHCO-EXXON, ipsec-ike-down, 686, \"IKE connection with peer 10.218.42.111 (routing-instance EXXON-Control-VR) is up\", USPAB\n\n"
"2021-12-04T01:29:14.807814+00:00 USHCO-EXXON, ipsec-tunnel-down, 872, \"IPSEC tunnel with peer 10.218.42.111 (routing-instance EXXON-Control-VR) is up\", USPAB\n\n"
"2021-12-04T01:29:14.807814+00:00 USHCO-EXXON, ipsec-ike-down, 871, \"IKE connection with peer 10.218.42.111 (routing-instance EXXON-Control-VR) is up\", USPAB")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.