import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(?:\\b(?=\\w*(?:fass|abeit))|\\G(?<!^))\\w*)a";
final String string = "verfassen verabeit passen fassabeit";
final String subst = "ä";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}