$re = '/(?<="pinyin": "[\w\s]*)\'(?!")/m';
$str = '"pinyin": "bei1 \'ai1",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);