$re = '/<txp::figure id="(.+?)"/m';
$str = '<txp::figure id="78" title="startseite" popup />
<p><a href="/?p=199286">Die 1. Kunst- und Holzwerkstatt faszinierte Kinder und Erwachsene</a></p>
<txp::figure id="82" title="Buslinie-12" popup />
<p><a href="/?p=199306">Keine Erweiterung der Linie 12 oberhalb der B.-Brecht-Straße</a></p>
<txp::figure id="80" title="Jenalog_Sirene1-startseite" popup />
<p>Für unsere Rubrik “Geschichte des Quartiers” suchen wir noch Bilder aus allen Jahrzehnten. Helfen Sie mit![/one_third_last]</p>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;