import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S)\\t[0-9]*\\R\\t+";
final String string = " 9.1 The Euclidean Group in Two-Dimensional 152\n"
+ " Space E2\n"
+ "CHAPTER 10: THE LORENTZ AND POINCARÉ GROUPS, \n"
+ " AND SPACE-TIME SYMMETRIES 173\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}