use strict;
my $str = ' 9.1 The Euclidean Group in Two-Dimensional 152
Space E2
CHAPTER 10: THE LORENTZ AND POINCARÉ GROUPS,
AND SPACE-TIME SYMMETRIES 173
';
my $regex = qr/(\S)\t[0-9]*\R\t+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";