// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/(\S*)\/(\S*)\/").unwrap();
let string = "https://mysite.ru/rostov-na-donu/products
https://mysite.ru/Рос тове-на-Дону/products";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}