import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\((\\d{4})(?:/[^)]*)?\\).*";
final String string = "\"You Are There\" (1953) {The Death of Socrates (399 B.C.) (#1.14)}\n"
+ "Þegar það gerist (1998/I) (TV)\n"
+ "Johannes Passion, BWV. 245 (1725 Version) (1996) (V)";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}