$re = '/(?<=\()\d+\.?\d?(?=g\))/m';
$str = 'blah blah blah 6521 (3.2g) 345 (8g) 34 etc...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);