#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?U)public(.|\n)+{"
Local $sString = " public ActionResult AddCompatibleWith(AttributeValue printer, string sku)" & @CRLF & _
" {" & @CRLF & _
" var isAuthenticated = _customerContext.LoggedInCustomer != null;" & @CRLF & _
" var model = new CompatibleWithModel();" & @CRLF & _
" if (isAuthenticated && _customerContext.LoggedInCustomer.SavedPrinters.Select(x => x.AttributeValue.Key).Contains(printer.Key))" & @CRLF & _
" {" & @CRLF & _
" model.Url = Url.Action(" & @CRLF & _
" "MyPrinters"," & @CRLF & _
" "Manage"," & @CRLF & _
" new" & @CRLF & _
" {" & @CRLF & _
" area = "my_account"" & @CRLF & _
" });" & @CRLF & _
" model.Text = SiteResources.View;" & @CRLF & _
" model.CssClass = "btn";" & @CRLF & _
" }" & @CRLF & _
" else"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")