import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public(.|\\n)+\\{";
final String string = " public ActionResult AddCompatibleWith(AttributeValue printer, string sku)\n"
+ " {\n"
+ " var isAuthenticated = _customerContext.LoggedInCustomer != null;\n"
+ " var model = new CompatibleWithModel();\n"
+ " if (isAuthenticated && _customerContext.LoggedInCustomer.SavedPrinters.Select(x => x.AttributeValue.Key).Contains(printer.Key))\n"
+ " {\n"
+ " model.Url = Url.Action(\n"
+ " \"MyPrinters\",\n"
+ " \"Manage\",\n"
+ " new\n"
+ " {\n"
+ " area = \"my_account\"\n"
+ " });\n"
+ " model.Text = SiteResources.View;\n"
+ " model.CssClass = \"btn\";\n"
+ " }\n"
+ " else";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}