# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"public(.|\n)+{"
test_str = (" public ActionResult AddCompatibleWith(AttributeValue printer, string sku)\n"
" {\n"
" var isAuthenticated = _customerContext.LoggedInCustomer != null;\n"
" var model = new CompatibleWithModel();\n"
" if (isAuthenticated && _customerContext.LoggedInCustomer.SavedPrinters.Select(x => x.AttributeValue.Key).Contains(printer.Key))\n"
" {\n"
" model.Url = Url.Action(\n"
" \"MyPrinters\",\n"
" \"Manage\",\n"
" new\n"
" {\n"
" area = \"my_account\"\n"
" });\n"
" model.Text = SiteResources.View;\n"
" model.CssClass = \"btn\";\n"
" }\n"
" else")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.