// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?U)public(.|\n)+{").unwrap();
let string = " public ActionResult AddCompatibleWith(AttributeValue printer, string sku)
{
var isAuthenticated = _customerContext.LoggedInCustomer != null;
var model = new CompatibleWithModel();
if (isAuthenticated && _customerContext.LoggedInCustomer.SavedPrinters.Select(x => x.AttributeValue.Key).Contains(printer.Key))
{
model.Url = Url.Action(
\"MyPrinters\",
\"Manage\",
new
{
area = \"my_account\"
});
model.Text = SiteResources.View;
model.CssClass = \"btn\";
}
else";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}