package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+(?<my_field>\w+)$`)
var str = `I have the below set of events where I wanted to write regex to capture only the last word
I have the below set of events where I wanted to write regex to capture only the last
I have the below set of events where I wanted to write regex to capture only the
I have the below set of events where I wanted to write regex to capture only`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}