$re = '/\b([^\s<>]{2,}[^\s\.<>](\.|:\/\/)[^\s\.<>][^\s<>]+)\b/m';
$str = 'sgsdg://sdfsdfg fgsg.sdgsg sgsdgs:sdgsdg 21.5c ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);