$re = '/^[0-9]{4,5}(;[0-9]{4,5})*$/m';
$str = '1111;11111;11111;1111;11111
111;11111;111111111
11111;11111;11111
111
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);