package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg`)
var str = `Rename:
[[:File:Example.jpg]]
Example.jpg
File:Example.jpg
[[File:Example.jpg|thumb]]
logo=Example.jpg
Do not rename:
Example filename is Example.jpg
[[:ru:Файл:Example.jpg]]
[[b:en:File:Example.jpg]]
[[:c:File:Example.jpg]]
duplicate=c:File:Example.jpg`
var substitution = "$1Renamed.jpg"
fmt.Println(re.ReplaceAllString(str, substitution))
}