use strict;
my $str = 'Rename:
[[:File:Example.jpg]]
Example.jpg
File:Example.jpg
[[File:Example.jpg|thumb]]
logo=Example.jpg
Do not rename:
Example filename is Example.jpg
[[:ru:Файл:Example.jpg]]
[[b:en:File:Example.jpg]]
[[:c:File:Example.jpg]]
duplicate=c:File:Example.jpg';
my $regex = qr/([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg/p;
my $subst = '$1Renamed.jpg';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";