$re = '/ex(?<GUID>\d+)d\@/m';
$str = 'ex095838d@mydomain.onmicrosoft.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);