$re = '/^[A-Za-z]{2}\d{3}$/m';
$str = 'ds123
ab333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);