$re = '/^(?:[7-9]|\d{2,})$/m';
$str = '0
1
2
3
4
5
6
7
8
9
10
11
12
256
1024
1000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);