# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+idIwant\\":{\\"(.+?)\\.+/$1/gm;t' <<< "{},\\"employees\\":{},\\"idIwant\\":{\\"2545\\":{\\"attributes\\":{\\"offset\\":9855,"