#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).+idIwant\\":{\\"(.+?)\\.+"
Local $sString = "{},\"employees\":{},\"idIwant\":{\"2545\":{\"attributes\":{\"offset\":9855,"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)