const regex = /^(?:\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\]\s[^[]+|[^[]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\\]\\s[^[]+|[^[]+)$', 'gm')
const str = `This Title Is Fine
[No Spoilers] This Title Is Fine
[S2 Act 2 Spoilers] This Title Is Fine
[Lore Spoilers] This Title Is Fine
[This Title] Is Not Fine
This Title Is Not Fine [No Spoilers]
[No Spoilers] This Title Is Not Fine [No Spoilers]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}