$re = '/^(?=.{4}$)(?![^no\n]*[no])(?=[^e\n]*e)[^i\n]*i.*$/m';
$str = 'one
two
three
four
five
six
seven
eight
nine
ten
eleven
twelve
tree';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);