#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^[^()\n]+"
Local $sString = "Auburn (Auburn University)[1]" & @CRLF & _
"Florence (University of North Alabama)" & @CRLF & _
"Jacksonville (Jacksonville State University)[2]" & @CRLF & _
"Livingston (University of West Alabama)[2]" & @CRLF & _
"Montevallo (University of Montevallo)[2]" & @CRLF & _
"Troy (Troy University)[2]" & @CRLF & _
"Tuscaloosa (University of Alabama, Stillman College, Shelton State)[3][4]" & @CRLF & _
"Tuskegee (Tuskegee University)[5]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")