$re = '/.*?(?<match>\(Foreign ID[0-9]{1,5}\)).*/m';
$str = '[GLPI #000001] Ticket subject with (Foreign ID00001) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);