using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(thedir[ ]*=[ ]*"")(.)(:[\/\\])([a-zA-Z0-9]*)([\/\\]?.*)$";
string substitution = @"$1Z$3Here$5";
string input = @"thedir=""C:/oneFolder/subfolder""
thedir=""C:/oneFolder/""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}