import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(thedir[ ]*=[ ]*\")(.)(:[\\/\\\\])([a-zA-Z0-9]*)([\\/\\\\]?.*)$";
final String string = "thedir=\"C:/oneFolder/subfolder\"\n"
+ "thedir=\"C:/oneFolder/\"";
final String subst = "$1Z$3Here$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}